FasCard/LaundryCard service outage

Incident Report for Card Concepts Inc.

Resolved

This Incident has been resolved.
Posted Oct 17, 2025 - 09:21 CDT

Update

We are continuing to investigate this issue.
Posted Oct 17, 2025 - 09:20 CDT

Update

We’re experiencing a service outage with our FasCard and LaundryCard datacenter. Our team is currently working to restore the service. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Oct 17, 2025 - 08:50 CDT

Investigating

We’re experiencing a service outage with our FasCard and LaundryCard datacenter. Our team is currently investigating. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Oct 17, 2025 - 08:36 CDT
This incident affected: FasCard / FLEX (admin.fascard.com, Mobile App, Satellite Connectivity, Credit Card Processing) and LaundryCard (live.laundrycard.com, Multi-Store / SYNC).